PIT01 - High Internet Latency

Incident Report for RedHelm Cloud

Resolved

The connection has remained stable. We are currently awaiting a root cause analysis (RCA) from the carrier. Once it is received, it will be made available upon request.
Posted Jul 22, 2026 - 09:31 EDT

Investigating

At approximately 5:20PM EDT, we experienced a period of very high latency on our primary internet carrier for several minutes. The connection has stabilized. We are currently investigating the root cause.
Posted Jul 20, 2026 - 17:31 EDT
This incident affected: PIT01 (Pittsburgh, PA) (Internet Connectivity).