This maintenance has been completed successfully. No issues were encountered.
Posted Mar 01, 2026 - 22:18 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 01, 2026 - 19:00 EST
Scheduled
We will be applying updates to our Nimble Storage array that services our PIT01 MGT environment. This update is to address a recently identified bug that has the potential to cause a controller to fail completely during an unexpected reboot resulting in a loss of controller redundancy. This update will also address a recently released security patch.
No downtime is anticipated, however, brief increases in storage latency are expected while controllers failover during the upgrade process. This array does not host client facing VMs but may affect access to other centralized services such as Veeam, FileCloud, and Cloud Director if issues are encountered.
Reference Ticket: 0468419
Posted Feb 27, 2026 - 15:12 EST
This scheduled maintenance affected: PIT01 (Pittsburgh, PA) (Storage Infrastructure).