Cooling issue at the datacenter

Incident Report for RedHelm Cloud

Resolved

The DC has resolved the cooling issue. We are continuing to monitor the temperature.
Posted May 20, 2026 - 11:16 EDT

Update

We are continuing to monitor the status of the cooling and adjusting as needed.
Posted May 19, 2026 - 13:01 EDT

Update

Temperatures remain stable. We will continue to monitor the status of the cooling in the datacenter.
Posted May 19, 2026 - 07:01 EDT

Update

Temperatures remain stable. We are continuing to monitor the status.
Posted May 19, 2026 - 00:50 EDT

Update

We are continuing to monitor the temperatures in the environment. If customers are still seeing issues, please call into our NOC to report the issue.
Posted May 18, 2026 - 23:16 EDT

Monitoring

Temperatures have stabilized, but we are continuing to monitor the situation.
Posted May 18, 2026 - 22:23 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 18, 2026 - 21:23 EDT

Update

Equipment is still recovering
Posted May 18, 2026 - 20:57 EDT

Update

Cooling issues are being addressed. Impacted equipment is being restored.
Posted May 18, 2026 - 20:34 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 18, 2026 - 20:14 EDT

Investigating

There is a cooling issue at the datacenter that has caused some equipment to overheat that is affecting accessibility of some hosted customer's VMs. We are working with the datacenter to rectify the issue as quickly as possible.
Posted May 18, 2026 - 20:14 EDT
This incident affected: PIT01 (Pittsburgh, PA) (Virtual Infrastructure, Network Infrastructure, Storage Infrastructure).